Linux On A Toshiba Click Mini...

Nicolas Huillard nicolas at
Mon Feb 29 09:34:41 CET 2016

Le dimanche 28 février 2016 à 20:15 +0000, Gee a écrit :
> I was wondering if the level of stability of my installation was
> actually the same as you guys, or whether it was more stable. I'm
> writing in the past as I had to use the SD card I had Debian installed
> on as a replacement for my phone. So I'll have to give it another try
> once I get a new SD card.
> Anyway, when I got Linux to boot and managed to login on the 4.2.8
> kernel I never had a problem with freezes. Granted, I didn't use it
> terribly much, but I had it running for a couple of hours to install
> texlive etc and tried out bits and pieces on occasion, so there would
> have been chances for freezes I guess.
> My problem was that maybe 3 out of 4 times I tried to start, the system
> would boot until the login screen, but then blank out before I managed
> to log in. I'm not sure if this is just a different aspect of the same
> problem you guys were facing, or if my config didn't have your problems,
> but different ones.

I suspect the freezes come from xorg and the video driver. I had bad
experiences during early Sandy Bridge iterations, all resolved using
either less demanding graphical environment, of improved drivers.
I currently have GDM on the machine, which seldom freezes at the
(graphical) login prompt. Gnome freezes very often, at random times (2
to 120 minutes after login). Openbox did freeze only once (very light
window manager), which using Evolution or some Gnome app. I didn't have
any freeze at all while using the machine remotely trough SSH, or
locally on the console.
I'd like to get XWayland to work on the machine, but was not yet able to
do so.

> As I mentioned in the thread, I had also tried to compile the 4.4.2
> kernel myself with Paul's config for 4.2.8, but the resulting kernel
> didn't support the keyboard or touchpad.
> I don't know if this was due to a problem with the kernel or (probably
> more likely as I've never compiled a kernel before) some mistake in my
> configuration of the various additional modules that weren't in the
> 4.2.8 config.

Having the keyboard/touchpad working on 4.3+ kernel is a matter of
patching and recompiling. The problem in those newer kernels is that the
ELAN0800 device is excluded from the PS/2 mouse emulation, but not
included in the actual Elan touchpad driver. The keyboard seems to be an
extension of the mouse. I was not able to have the proper touchpad
driver to work (had freeze at modprobe).
The patch consists of commenting out the following line from
"drivers/hid/hid-core.c" :
        // 	{ HID_I2C_DEVICE(USB_VENDOR_ID_ELAN, 0x0401) },

> @Paul, did you do anything special in addition to the kernel
> configurations available on your server in order to get the keyboard to
> work?

See above. Attached is my current config.

> On 28/02/16 16:09, Paul Mansfield wrote:
> > I am wondering if there's a problem setting up the interrupt hardware
> > on the baytrail SoC, which is why certain things trigger a hard
> > lockup. Even without the SDIO WiFi, I would occasionally get one - I
> > was using XFCE which shouldn't be too demanding on the hardware.

I think the XFCE can trigger xorg freezes just as any other X window
manager/application. Less frequent than Gnome, but more frequent than

> > The frustrating thing about this is that there are stable kernels
> > around for this SoC, since Baytrails have been used in
> > commercially-sold Android devices, and Intel sold their compute stick
> > with the same chip and wifi (though despite repeated requests I didn't
> > persuade Intel to publish the disk image when I tried months ago)

The common point of all these Android/Linux systems running on this chip
is that they do not use X...

Nicolas Huillard
nicolas at
Fixe : +33 9 52 31 06 10
Mobile : +33 6 50 27 69 08
-------------- next part --------------
A non-text attachment was scrubbed...
Name: .config
Type: text/x-mpsub
Size: 148525 bytes
Desc: not available
URL: <>

More information about the click mailing list