Fix weight comparison in edge BFS
[tinc] / test / unit / meson.build
index d83a080..5200598 100644 (file)
@@ -21,6 +21,9 @@ link_tincd = { 'lib': lib_tincd, 'dep': deps_tincd }
 # }
 
 tests = {
+  'dropin': {
+    'code': 'test_dropin.c',
+  },
   'random': {
     'code': 'test_random.c',
   },
@@ -28,6 +31,12 @@ tests = {
     'code': 'test_random_noinit.c',
     'fail': true,
   },
+  'graph': {
+    'code': 'test_graph.c',
+  },
+  'netutl': {
+    'code': 'test_netutl.c',
+  },
   'net': {
     'code': 'test_net.c',
     'mock': ['execute_script', 'environment_init', 'environment_exit'],
@@ -38,6 +47,19 @@ tests = {
   'protocol': {
     'code': 'test_protocol.c',
   },
+  'proxy': {
+    'code': 'test_proxy.c',
+  },
+  'utils': {
+    'code': 'test_utils.c',
+  },
+  'xalloc': {
+    'code': 'test_xalloc.c',
+  },
+  'memzero_null': {
+    'code': 'test_memzero_null.c',
+    'fail': true,
+  },
   'splay_tree': {
     'code': 'test_splay_tree.c',
     'link': link_tinc,