Fix building tinc and running tests on Solaris
[tinc] / test / integration / meson.build
index 1c3b9ea..ef33b08 100644 (file)
@@ -6,7 +6,6 @@ tests = [
   'invite-join.test',
   'invite-offline.test',
   'invite-tinc-up.test',
-  'scripts.test',
   'security.test',
   'variables.test',
 ]
@@ -24,6 +23,10 @@ if os_name == 'linux'
   tests += 'ns-ping.test'
 endif
 
+if os_name != 'sunos'
+  tests += 'scripts.test'
+endif
+
 exe_splice = executable(
   'splice',
   sources: 'splice.c',