Revert "Work around a GCC bug that causes inet_checksum() to give wrong results."
[tinc] / test / Makefile.am
index 15db24f..dae30dc 100644 (file)
@@ -1,10 +1,26 @@
 TESTS = \
        basic.test \
+       commandline.test \
        executables.test \
        import-export.test \
-       sptps-basic.test
+       invite-join.test \
+       invite-offline.test \
+       invite-tinc-up.test \
+       legacy-protocol.test \
+       ns-ping.test \
+       scripts.test \
+       security.test \
+       sptps-basic.test \
+       variables.test
 
-EXTRA_DIST = testlib.sh
+dist_check_SCRIPTS = $(TESTS)
+
+AM_CFLAGS = -iquote.
+
+check_PROGRAMS = \
+       splice
+
+splice_SOURCES = splice.c
 
 clean-local:
        -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done