Prevent oracle attacks in the legacy protocol (CVE-2018-16737, CVE-2018-16738)
[tinc] / test / Makefile.am
index 29b2c21..9c2f001 100644 (file)
@@ -8,6 +8,7 @@ TESTS = \
        invite-tinc-up.test \
        ns-ping.test \
        scripts.test \
+       security.test \
        sptps-basic.test \
        variables.test
 
@@ -17,6 +18,11 @@ EXTRA_DIST = testlib.sh
 
 AM_CFLAGS = -iquote.
 
+check_PROGRAMS = \
+       splice
+
+splice_SOURCES = splice.c
+
 clean-local:
        -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
        -killall ../src/sptps_test