Rewrite the test suite for better compat and stability
[tinc] / test / Makefile.am
index dae30dc..8c8d08f 100644 (file)
@@ -1,17 +1,25 @@
 TESTS = \
        basic.test \
-       commandline.test \
        executables.test \
+       commandline.test \
        import-export.test \
        invite-join.test \
        invite-offline.test \
        invite-tinc-up.test \
-       legacy-protocol.test \
-       ns-ping.test \
+       variables.test \
        scripts.test \
        security.test \
-       sptps-basic.test \
-       variables.test
+       sptps-basic.test
+
+if WITH_LEGACY_PROTOCOL
+TESTS += \
+        legacy-protocol.test \
+        algorithms.test
+endif
+
+if LINUX
+TESTS += ns-ping.test
+endif
 
 dist_check_SCRIPTS = $(TESTS)