Add cleanup hook for integration tests
[tinc] / test / Makefile.am
index 98f4a3b..8c8d08f 100644 (file)
@@ -1,27 +1,36 @@
 TESTS = \
        basic.test \
-       commandline.test \
        executables.test \
+       commandline.test \
        import-export.test \
        invite-join.test \
        invite-offline.test \
        invite-tinc-up.test \
-       ns-ping.test \
-       ping.test \
+       variables.test \
        scripts.test \
-       sptps-basic.test \
-       variables.test
+       security.test \
+       sptps-basic.test
+
+if WITH_LEGACY_PROTOCOL
+TESTS += \
+        legacy-protocol.test \
+        algorithms.test
+endif
+
+if LINUX
+TESTS += ns-ping.test
+endif
 
 dist_check_SCRIPTS = $(TESTS)
 
-EXTRA_DIST = testlib.sh
+AM_CFLAGS = -iquote.
 
-check_PROGRAMS = pong
+check_PROGRAMS = \
+       splice
 
-pong_SOURCES = pong.c
+splice_SOURCES = splice.c
 
 clean-local:
        -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
        -killall ../src/sptps_test
-       -killall pong
        -rm -rf *.test.?