Rewrite the test suite for better compat and stability
[tinc] / test / Makefile.am
index 29b2c21..8c8d08f 100644 (file)
@@ -1,22 +1,35 @@
 TESTS = \
        basic.test \
-       commandline.test \
        executables.test \
+       commandline.test \
        import-export.test \
        invite-join.test \
        invite-offline.test \
        invite-tinc-up.test \
-       ns-ping.test \
+       variables.test \
        scripts.test \
-       sptps-basic.test \
-       variables.test
+       security.test \
+       sptps-basic.test
 
-dist_check_SCRIPTS = $(TESTS)
+if WITH_LEGACY_PROTOCOL
+TESTS += \
+        legacy-protocol.test \
+        algorithms.test
+endif
 
-EXTRA_DIST = testlib.sh
+if LINUX
+TESTS += ns-ping.test
+endif
+
+dist_check_SCRIPTS = $(TESTS)
 
 AM_CFLAGS = -iquote.
 
+check_PROGRAMS = \
+       splice
+
+splice_SOURCES = splice.c
+
 clean-local:
        -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
        -killall ../src/sptps_test