Add a test for invite and join commands.
[tinc] / test / Makefile.am
index 69042ac..4766004 100644 (file)
@@ -1,9 +1,13 @@
 TESTS = \
-       executables.test \
        basic.test \
-       sptps_basic.test
+       executables.test \
+       import-export.test \
+       invite-join.test \
+       sptps-basic.test
 
 EXTRA_DIST = testlib.sh
 
 clean-local:
+       -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
+       -killall ../src/sptps_test
        -rm -rf *.test.?