Remove the ping test.
[tinc] / test / Makefile.am
index 69042ac..29b2c21 100644 (file)
@@ -1,9 +1,23 @@
 TESTS = \
-       executables.test \
        basic.test \
-       sptps_basic.test
+       commandline.test \
+       executables.test \
+       import-export.test \
+       invite-join.test \
+       invite-offline.test \
+       invite-tinc-up.test \
+       ns-ping.test \
+       scripts.test \
+       sptps-basic.test \
+       variables.test
+
+dist_check_SCRIPTS = $(TESTS)
 
 EXTRA_DIST = testlib.sh
 
+AM_CFLAGS = -iquote.
+
 clean-local:
+       -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
+       -killall ../src/sptps_test
        -rm -rf *.test.?