Merge remote-tracking branch 'volth/release-1.1pre16-rtt' into 1.1
[tinc] / test / Makefile.am
index 15db24f..29b2c21 100644 (file)
@@ -1,11 +1,22 @@
 TESTS = \
        basic.test \
+       commandline.test \
        executables.test \
        import-export.test \
-       sptps-basic.test
+       invite-join.test \
+       invite-offline.test \
+       invite-tinc-up.test \
+       ns-ping.test \
+       scripts.test \
+       sptps-basic.test \
+       variables.test
+
+dist_check_SCRIPTS = $(TESTS)
 
 EXTRA_DIST = testlib.sh
 
+AM_CFLAGS = -iquote.
+
 clean-local:
        -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
        -killall ../src/sptps_test