Support running tests on NetBSD 8.2.
[tinc] / test / Makefile.am
index 9c2f001..20fee65 100644 (file)
@@ -1,20 +1,30 @@
 TESTS = \
        basic.test \
-       commandline.test \
        executables.test \
+       commandline.test \
+       command-fsck.test \
        import-export.test \
        invite-join.test \
        invite-offline.test \
        invite-tinc-up.test \
-       ns-ping.test \
+       variables.test \
        scripts.test \
        security.test \
-       sptps-basic.test \
-       variables.test
+       sptps-basic.test
 
-dist_check_SCRIPTS = $(TESTS)
+if WITH_LEGACY_PROTOCOL
+TESTS += \
+       legacy-protocol.test \
+       algorithms.test
+endif
 
-EXTRA_DIST = testlib.sh
+if LINUX
+TESTS += \
+       ns-ping.test \
+       compression.test
+endif
+
+dist_check_SCRIPTS = $(TESTS)
 
 AM_CFLAGS = -iquote.