Restore libgcrypt support.
[tinc] / test / Makefile.am
index dac577d..0ba4da9 100644 (file)
@@ -1,21 +1,42 @@
 TESTS = \
        basic.test \
-       commandline.test \
        executables.test \
+       commandline.test \
+       command-fsck.test \
        import-export.test \
        invite-join.test \
-       ping.test \
-       sptps-basic.test \
-       variables.test
+       invite-offline.test \
+       invite-tinc-up.test \
+       variables.test \
+       scripts.test \
+       security.test \
+       sptps-basic.test
+
+if WITH_LEGACY_PROTOCOL
+TESTS += \
+       legacy-protocol.test \
+       algorithms.test
+endif
+
+if LINUX
+TESTS += \
+       ns-ping.test \
+       compression.test
+endif
+
+dist_check_SCRIPTS = $(TESTS)
+
+AM_CFLAGS = -iquote.
 
-EXTRA_DIST = testlib.sh
+check_PROGRAMS = \
+       splice
 
-check_PROGRAMS = pong
+splice_SOURCES = splice.c
 
-pong_SOURCES = pong.c
+.PHONY: extra
+extra: $(check_PROGRAMS)
 
 clean-local:
        -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
        -killall ../src/sptps_test
-       -killall pong
        -rm -rf *.test.?