Restore libgcrypt support.
[tinc] / test / Makefile.am
index 9c2f001..0ba4da9 100644 (file)
@@ -1,20 +1,30 @@
 TESTS = \
        basic.test \
-       commandline.test \
        executables.test \
+       commandline.test \
+       command-fsck.test \
        import-export.test \
        invite-join.test \
        invite-offline.test \
        invite-tinc-up.test \
-       ns-ping.test \
+       variables.test \
        scripts.test \
        security.test \
-       sptps-basic.test \
-       variables.test
+       sptps-basic.test
 
-dist_check_SCRIPTS = $(TESTS)
+if WITH_LEGACY_PROTOCOL
+TESTS += \
+       legacy-protocol.test \
+       algorithms.test
+endif
 
-EXTRA_DIST = testlib.sh
+if LINUX
+TESTS += \
+       ns-ping.test \
+       compression.test
+endif
+
+dist_check_SCRIPTS = $(TESTS)
 
 AM_CFLAGS = -iquote.
 
@@ -23,6 +33,9 @@ check_PROGRAMS = \
 
 splice_SOURCES = splice.c
 
+.PHONY: extra
+extra: $(check_PROGRAMS)
+
 clean-local:
        -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
        -killall ../src/sptps_test