Extract common logic in OpenSSL-specific code
[tinc] / test / Makefile.am
index 4766004..0ba4da9 100644 (file)
@@ -1,11 +1,40 @@
 TESTS = \
        basic.test \
        executables.test \
+       commandline.test \
+       command-fsck.test \
        import-export.test \
        invite-join.test \
+       invite-offline.test \
+       invite-tinc-up.test \
+       variables.test \
+       scripts.test \
+       security.test \
        sptps-basic.test
 
-EXTRA_DIST = testlib.sh
+if WITH_LEGACY_PROTOCOL
+TESTS += \
+       legacy-protocol.test \
+       algorithms.test
+endif
+
+if LINUX
+TESTS += \
+       ns-ping.test \
+       compression.test
+endif
+
+dist_check_SCRIPTS = $(TESTS)
+
+AM_CFLAGS = -iquote.
+
+check_PROGRAMS = \
+       splice
+
+splice_SOURCES = splice.c
+
+.PHONY: extra
+extra: $(check_PROGRAMS)
 
 clean-local:
        -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done