Add basic pledge/unveil sandbox on OpenBSD
[tinc] / src / meson.build
index 1d195cf..564ef6f 100644 (file)
@@ -62,6 +62,7 @@ check_headers = [
   'sys/ioctl.h',
   'sys/mman.h',
   'sys/param.h',
+  'sys/random.h',
   'sys/resource.h',
   'sys/socket.h',
   'sys/stat.h',
@@ -85,6 +86,7 @@ check_functions = [
   'explicit_bzero',
   'explicit_memset',
   'fchmod',
+  'getentropy',
   'gettimeofday',
   'memset_s',
   'mlockall',
@@ -172,6 +174,7 @@ src_tincd = [
   'subnet.c',
 ]
 
+cc_flags_tinc = cc_flags
 cc_flags_tincd = cc_flags
 
 deps_common = []
@@ -267,6 +270,9 @@ if not opt_curses.disabled()
   if dep_curses.found()
     cdata.set('HAVE_CURSES', 1)
     deps_tinc += dep_curses
+    if static
+      cc_flags_tinc += '-DNCURSES_STATIC'
+    endif
   endif
 endif
 
@@ -278,6 +284,9 @@ else
   if not dep_readline.found()
     dep_readline = cc.find_library('readline', required: opt_readline, static: static)
   endif
+  if not dep_readline.found()
+    dep_readline = cc.find_library('libedit', required: opt_readline, static: static)
+  endif
   if dep_readline.found() and \
      cc.has_header('readline/readline.h', dependencies: dep_readline) and \
      cc.has_header('readline/history.h', dependencies: dep_readline)
@@ -359,6 +368,11 @@ endif
 
 subdir('include')
 
+have_sandbox = cdata.has('HAVE_SANDBOX')
+if not have_sandbox
+  src_lib_common += 'sandbox.c'
+endif
+
 lib_crypto = static_library(
   'tinc_crypto',
   sources: src_lib_crypto,
@@ -387,6 +401,7 @@ lib_tinc = static_library(
   sources: src_tinc,
   dependencies: deps_tinc,
   link_with: lib_common,
+  c_args: cc_flags_tinc,
   implicit_include_directories: false,
   include_directories: inc_conf,
   build_by_default: false,