Replace getrandom() with getentropy()
[tinc] / src / meson.build
index 351124e..02a4283 100644 (file)
@@ -62,6 +62,7 @@ check_headers = [
   'sys/ioctl.h',
   'sys/mman.h',
   'sys/param.h',
+  'sys/random.h',
   'sys/resource.h',
   'sys/socket.h',
   'sys/stat.h',
@@ -85,6 +86,7 @@ check_functions = [
   'explicit_bzero',
   'explicit_memset',
   'fchmod',
+  'getentropy',
   'gettimeofday',
   'memset_s',
   'mlockall',