BSD: add kqueue support
[tinc] / src / bsd / meson.build
index e6062dc..91bc550 100644 (file)
@@ -6,6 +6,11 @@ check_headers += [
   'net/tun/if_tun.h',
 ]
 
+# macOS apparently doesn't support kqueue with TAP devices
+if os_name != 'darwin'
+  check_headers += 'sys/event.h'
+endif
+
 check_functions += [
   'devname',
   'fdevname',