Use nostdinc instead of overriding DEFAULT_INCLUDES.
[tinc] / src / Makefile.am
index 63af709..dacfbfc 100644 (file)
@@ -13,8 +13,6 @@ if LINUX
 sbin_PROGRAMS += sptps_speed
 endif
 
-DEFAULT_INCLUDES =
-
 ed25519_SOURCES = \
        ed25519/add_scalar.c \
        ed25519/ed25519.h \
@@ -251,6 +249,12 @@ sptps_speed_SOURCES += \
 endif
 endif
 
+if MINIUPNPC
+tincd_SOURCES += upnp.h upnp.c
+tincd_LDADD = $(MINIUPNPC_LIBS)
+tincd_LDFLAGS = -pthread
+endif
+
 tinc_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
 sptps_speed_LDADD = -lrt