Use nostdinc instead of overriding DEFAULT_INCLUDES.
[tinc] / src / Makefile.am
index 3b9843a..dacfbfc 100644 (file)
@@ -3,18 +3,16 @@
 sbin_PROGRAMS = tincd tinc sptps_test sptps_keypair
 
 ## Make sure version.c is always rebuilt with the latest git information
-.PHONY: version.c version_git.h
+.PHONY: ${srcdir}/version.c version_git.h
 version_git.h:
        echo >$@
-       -git describe && echo '#define GIT_DESCRIPTION "'`git describe | sed 's/release-//'`'"' >$@
-version.c: version_git.h
+       -(cd $(srcdir) && git describe) && echo '#define GIT_DESCRIPTION "'`(cd $(srcdir) && git describe) | sed 's/release-//'`'"' >$@
+${srcdir}/version.c: version_git.h
 
 if LINUX
 sbin_PROGRAMS += sptps_speed
 endif
 
-DEFAULT_INCLUDES =
-
 ed25519_SOURCES = \
        ed25519/add_scalar.c \
        ed25519/ed25519.h \
@@ -94,7 +92,7 @@ tincd_SOURCES = \
        tincd.c \
        utils.c utils.h \
        xalloc.h \
-       version.c version.h version_git.h \
+       version.c version.h \
        ed25519/ecdh.c \
        ed25519/ecdsa.c \
        $(ed25519_SOURCES) \
@@ -116,7 +114,7 @@ tinc_SOURCES = \
        tincctl.c tincctl.h \
        top.c top.h \
        utils.c utils.h \
-       version.c version.h version_git.h \
+       version.c version.h \
        ed25519/ecdh.c \
        ed25519/ecdsa.c \
        ed25519/ecdsagen.c \
@@ -251,6 +249,12 @@ sptps_speed_SOURCES += \
 endif
 endif
 
+if MINIUPNPC
+tincd_SOURCES += upnp.h upnp.c
+tincd_LDADD = $(MINIUPNPC_LIBS)
+tincd_LDFLAGS = -pthread
+endif
+
 tinc_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
 sptps_speed_LDADD = -lrt
 
@@ -260,4 +264,4 @@ if TUNEMU
 LIBS += -lpcap
 endif
 
-AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"
+AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\" -iquote.