Remember sockaddrs of listening sockets, use appropriate one when sending
[tinc] / src / Makefile.am
index 862f732..d769071 100644 (file)
@@ -1,15 +1,18 @@
 ## Produce this file with automake to get Makefile.in
-# $Id: Makefile.am,v 1.4.4.14 2001/10/13 13:53:07 guus Exp $
+# $Id: Makefile.am,v 1.4.4.20 2002/02/18 16:25:16 guus Exp $
 
 sbin_PROGRAMS = tincd
 
-tincd_SOURCES = conf.c connection.c device.c meta.c net.c netutl.c node.c process.c    \
-       protocol.c route.c subnet.c tincd.c vertex.c
+EXTRA_DIST = linux/device.c freebsd/device.c openbsd/device.c solaris/device.c
+
+tincd_SOURCES = conf.c connection.c device.c edge.c event.c graph.c meta.c net.c net_packet.c net_setup.c      \
+       net_socket.c netutl.c node.c process.c protocol.c protocol_auth.c protocol_edge.c protocol_misc.c       \
+       protocol_key.c protocol_subnet.c route.c subnet.c tincd.c
 
 INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib -I$(top_srcdir)/intl
 
-noinst_HEADERS = conf.h connection.h device.h meta.h net.h netutl.h node.h process.h   \
-       protocol.h route.h subnet.h vertex.h
+noinst_HEADERS = conf.h connection.h device.h edge.h event.h graph.h meta.h net.h netutl.h node.h process.h    \
+       protocol.h route.h subnet.h
 
 LIBS = @LIBS@ @INTLLIBS@