Attribution for Vil Brekin and some code style cleanups.
[tinc] / src / Makefile.am
index a1ec352..cd44eb6 100644 (file)
@@ -1,19 +1,45 @@
 ## Produce this file with automake to get Makefile.in
-# $Id: Makefile.am,v 1.4.4.6 2000/11/15 13:33:25 guus Exp $
 
 sbin_PROGRAMS = tincd
 
-tincd_SOURCES = conf.c connlist.c meta.c net.c netutl.c protocol.c subnet.c tincd.c
+EXTRA_DIST = linux/device.c bsd/device.c solaris/device.c cygwin/device.c mingw/device.c mingw/common.h
 
-INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib -I$(top_srcdir)/intl
+tincd_SOURCES = conf.c connection.c edge.c event.c graph.c logger.c meta.c net.c net_packet.c net_setup.c      \
+       net_socket.c netutl.c node.c process.c protocol.c protocol_auth.c protocol_edge.c protocol_misc.c       \
+       protocol_key.c protocol_subnet.c route.c subnet.c tincd.c \
+       dummy_device.c raw_socket_device.c multicast_device.c
+       
+if UML
+tincd_SOURCES += uml_device.c
+endif
 
-noinst_HEADERS = conf.h connlist.h meta.h net.h netutl.h protocol.h subnet.h
+if VDE
+tincd_SOURCES += vde_device.c
+endif
 
-LIBS = @LIBS@ @INTLLIBS@
+if TUNEMU
+tincd_SOURCES += bsd/tunemu.c
+endif
+
+nodist_tincd_SOURCES = device.c
+
+DEFAULT_INCLUDES =
+
+INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib
+
+noinst_HEADERS = conf.h connection.h device.h edge.h event.h graph.h logger.h meta.h net.h netutl.h node.h process.h   \
+       protocol.h route.h subnet.h bsd/tunemu.h
+
+LIBS = @LIBS@
+
+if TUNEMU
+LIBS += -lpcap
+endif
 
 tincd_LDADD = \
        $(top_builddir)/lib/libvpn.a
 
-localedir = $(datadir)/locale
+AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\"
 
-CFLAGS = @CFLAGS@ -DPKGLIBDIR=$(pkglibdir) -DCONFDIR=\"@sysconfdir@\" -DLOCALEDIR=\"$(localedir)\"
+dist-hook:
+       rm -f `find . -type l`