Do not include $(top_srcdir)/cipher, it does no longer exist.
[tinc] / src / Makefile.am
index 2cd0df4..7ef3ab3 100644 (file)
@@ -1,21 +1,19 @@
 ## Produce this file with automake to get Makefile.in
+# $Id: Makefile.am,v 1.4.4.5 2000/11/02 21:26:51 zarq Exp $
 
-sbin_PROGRAMS = tincd genauth
+sbin_PROGRAMS = tincd
 
-genauth_SOURCES = genauth.c
-tincd_SOURCES = conf.c encr.c net.c netutl.c protocol.c tincd.c
+tincd_SOURCES = conf.c connlist.c meta.c net.c netutl.c protocol.c subnet.c tincd.c
 
-INCLUDES = -I$(top_builddir) -I$(top_srcdir)/cipher -I$(top_srcdir)/lib
+INCLUDES = -I$(top_builddir) -I$(top_srcdir)/lib -I$(top_srcdir)/intl
 
-noinst_HEADERS = conf.h encr.h net.h netutl.h protocol.h
+noinst_HEADERS = conf.h connlist.h meta.h net.h netutl.h protocol.h subnet.h
 
-LIBS = @LIBS@
+LIBS = @LIBS@ @INTLLIBS@
 
-tincd_LDADD = $(top_builddir)/cipher/libcipher.la \
+tincd_LDADD = \
        $(top_builddir)/lib/libvpn.a
 
-genauth_LDADD = $(top_builddir)/lib/libvpn.a
-
 localedir = $(datadir)/locale
 
 CFLAGS = @CFLAGS@ -DPKGLIBDIR=$(pkglibdir) -DCONFDIR=\"@sysconfdir@\" -DLOCALEDIR=\"$(localedir)\"