Make autoconnect try to heal network splits.
[tinc] / src / Makefile.am
index 794e420..7be46d9 100644 (file)
@@ -1,6 +1,7 @@
 ## Produce this file with automake to get Makefile.in
 
 sbin_PROGRAMS = tincd tinc
+check_PROGRAMS = sptps_test sptps_keypair
 EXTRA_PROGRAMS = sptps_test sptps_keypair
 
 CLEANFILES = version_git.h
@@ -23,7 +24,6 @@ EXTRA_PROGRAMS += sptps_speed
 endif
 
 ed25519_SOURCES = \
-       ed25519/add_scalar.c \
        ed25519/ed25519.h \
        ed25519/fe.c ed25519/fe.h \
        ed25519/fixedint.h \
@@ -42,6 +42,7 @@ chacha_poly1305_SOURCES = \
        chacha-poly1305/poly1305.c chacha-poly1305/poly1305.h
 
 tincd_SOURCES = \
+       autoconnect.c autoconnect.h \
        buffer.c buffer.h \
        cipher.h \
        conf.c conf.h \