Make autoconnect try to heal network splits.
[tinc] / src / Makefile.am
index 200c71f..7be46d9 100644 (file)
@@ -1,6 +1,8 @@
 ## Produce this file with automake to get Makefile.in
 
-sbin_PROGRAMS = tincd tinc sptps_test sptps_keypair
+sbin_PROGRAMS = tincd tinc
+check_PROGRAMS = sptps_test sptps_keypair
+EXTRA_PROGRAMS = sptps_test sptps_keypair
 
 CLEANFILES = version_git.h
 
@@ -18,11 +20,10 @@ version.c: ${srcdir}/version.c
 endif
 
 if LINUX
-sbin_PROGRAMS += sptps_speed
+EXTRA_PROGRAMS += sptps_speed
 endif
 
 ed25519_SOURCES = \
-       ed25519/add_scalar.c \
        ed25519/ed25519.h \
        ed25519/fe.c ed25519/fe.h \
        ed25519/fixedint.h \
@@ -41,6 +42,7 @@ chacha_poly1305_SOURCES = \
        chacha-poly1305/poly1305.c chacha-poly1305/poly1305.h
 
 tincd_SOURCES = \
+       autoconnect.c autoconnect.h \
        buffer.c buffer.h \
        cipher.h \
        conf.c conf.h \
@@ -58,6 +60,7 @@ tincd_SOURCES = \
        edge.c edge.h \
        ethernet.h \
        event.c event.h \
+       fd_device.c \
        graph.c graph.h \
        hash.c hash.h \
        have.h \