Use hardcoded value for TUNNEWPPA if net/if_tun.h is missing on Solaris.
[tinc] / doc / Makefile.am
index c3b209f..8e854bc 100644 (file)
@@ -2,17 +2,11 @@
 
 info_TEXINFOS = tinc.texi
 
-dyn_MANS =
-man_aux = $(dyn_MANS:.8=.x)
+man_MANS = tincd.8 tinc.conf.5
 
-man_MANS = tincd.8 tinc.conf.5 $(dyn_MANS)
+EXTRA_DIST = tincinclude.texi.in tincd.8.in tinc.conf.5.in sample-config.tar.gz
 
-PERL = @PERL@
-HELP2MAN = help2man
-MAINTAINERCLEANFILES = $(dyn_MANS)
-
-EXTRA_DIST = $(man_MANS) $(HELP2MAN) $(man_aux) \
-  Makefile.maint GNUmakefile Makefile.summ sample-config.tar.gz
+CLEANFILES = *.html tincd.8 tinc.conf.5 tincinclude.texi
 
 # Use `ginstall' in the definition of man_MANS to avoid
 # confusion with the `install' target.  The install rule transforms `ginstall'
@@ -22,13 +16,31 @@ transform = s/ginstall/install/; @program_transform_name@
 # For additional rules usually of interest only to the maintainer,
 # see GNUmakefile and Makefile.maint.
 
-tinc.pdf: tinc.texi
-       texi2pdf -o tinc.pdf tinc.texi
+sample-config.tar.gz: sample-config
+       GZIP=$(GZIP_ENV) $(AMTAR) chozf sample-config.tar.gz --exclude .svn sample-config
 
 texi2html: tinc.texi
-       mkdir -p html
-       rm -f html/*.html
-       cd html && texi2html -split=chapter ../tinc.texi
+       texi2html -split=chapter tinc.texi
+
+tincd.8.html: tincd.8
+       w3mman2html $< > $@
 
-%.html: %
+tinc.conf.5.html: tinc.conf.5
        w3mman2html $< > $@
+
+substitute = sed \
+       -e s,'@PACKAGE\@',"$(PACKAGE)",g \
+       -e s,'@VERSION\@',"$(VERSION)",g \
+       -e s,'@sysconfdir\@',"$(sysconfdir)",g \
+       -e s,'@localstatedir\@',"$(localstatedir)",g
+
+tincd.8: tincd.8.in
+       $(substitute) tincd.8.in > tincd.8
+
+tinc.conf.5: tinc.conf.5.in
+       $(substitute) tinc.conf.5.in > tinc.conf.5
+
+tincinclude.texi: tincinclude.texi.in
+       $(substitute) tincinclude.texi.in > tincinclude.texi
+       
+tinc.texi: tincinclude.texi