Fix building documentation when using OpenBSD's make.
[tinc] / doc / Makefile.am
index f1aa7fb..60afb12 100644 (file)
@@ -4,23 +4,33 @@ info_TEXINFOS = tinc.texi
 
 man_MANS = tincd.8 tinc.conf.5
 
-EXTRA_DIST = tincinclude.texi.in tincd.8.in tinc.conf.5.in sample-config.tar.gz
+EXTRA_DIST = tincinclude.texi.in tincd.8.in tinc.conf.5.in sample-config
 
-CLEANFILES = *.html
+CLEANFILES = *.html tincd.8 tinc.conf.5 tincinclude.texi tinc.info
 
-# Use `ginstall' in the definition of man_MANS to avoid
-# confusion with the `install' target.  The install rule transforms `ginstall'
-# to install before applying any user-specified name transformations.
-transform = s/ginstall/install/; @program_transform_name@
+texi2html: tinc.texi
+       $(AM_V_GEN)texi2html -split=chapter $<
 
-# For additional rules usually of interest only to the maintainer,
-# see GNUmakefile and Makefile.maint.
+tincd.8.html: tincd.8
+       $(AM_V_GEN)w3mman2html $< > $@
 
-sample-config.tar.gz: sample-config
-       GZIP=$(GZIP_ENV) $(AMTAR) chozf sample-config.tar.gz sample-config
+tinc.conf.5.html: tinc.conf.5
+       $(AM_V_GEN)w3mman2html $< > $@
 
-texi2html: tinc.texi
-       texi2html -split=chapter tinc.texi
+substitute = sed \
+       -e s,'@PACKAGE\@',"$(PACKAGE)",g \
+       -e s,'@VERSION\@',"$(VERSION)",g \
+       -e s,'@sysconfdir\@',"$(sysconfdir)",g \
+       -e s,'@runstatedir\@',"$(runstatedir)",g \
+       -e s,'@localstatedir\@',"$(localstatedir)",g
+
+tincd.8: $(srcdir)/tincd.8.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tincd.8.in > $@
+
+tinc.conf.5: $(srcdir)/tinc.conf.5.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tinc.conf.5.in > $@
+
+tincinclude.texi: $(srcdir)/tincinclude.texi.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tincinclude.texi.in > $@
 
-%.html: $(man_MANS)
-       w3mman2html $< > $@
+tinc.texi: tincinclude.texi