Fix building documentation when using OpenBSD's make.
[tinc] / doc / Makefile.am
index 9f3f7eb..60afb12 100644 (file)
@@ -1,25 +1,36 @@
 ## Process this file with automake to get Makefile.in
 
-SUBDIRS = es
-
 info_TEXINFOS = tinc.texi
 
-dyn_MANS =
-man_aux = $(dyn_MANS:.8=.x)
+man_MANS = tincd.8 tinc.conf.5
+
+EXTRA_DIST = tincinclude.texi.in tincd.8.in tinc.conf.5.in sample-config
+
+CLEANFILES = *.html tincd.8 tinc.conf.5 tincinclude.texi tinc.info
+
+texi2html: tinc.texi
+       $(AM_V_GEN)texi2html -split=chapter $<
+
+tincd.8.html: tincd.8
+       $(AM_V_GEN)w3mman2html $< > $@
+
+tinc.conf.5.html: tinc.conf.5
+       $(AM_V_GEN)w3mman2html $< > $@
 
-man_MANS = tincd.8 tinc.conf.5 genauth.8 $(dyn_MANS)
+substitute = sed \
+       -e s,'@PACKAGE\@',"$(PACKAGE)",g \
+       -e s,'@VERSION\@',"$(VERSION)",g \
+       -e s,'@sysconfdir\@',"$(sysconfdir)",g \
+       -e s,'@runstatedir\@',"$(runstatedir)",g \
+       -e s,'@localstatedir\@',"$(localstatedir)",g
 
-PERL = @PERL@
-HELP2MAN = help2man
-MAINTAINERCLEANFILES = $(dyn_MANS)
+tincd.8: $(srcdir)/tincd.8.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tincd.8.in > $@
 
-EXTRA_DIST = $(man_MANS) $(HELP2MAN) $(man_aux) \
-  Makefile.maint GNUmakefile Makefile.summ tinc.conf.sample
+tinc.conf.5: $(srcdir)/tinc.conf.5.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tinc.conf.5.in > $@
 
-# Use `ginstall' in the definition of man_MANS to avoid
-# confusion with the `install' target.  The install rule transforms `ginstall'
-# to install before applying any user-specified name transformations.
-transform = s/ginstall/install/; @program_transform_name@
+tincinclude.texi: $(srcdir)/tincinclude.texi.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tincinclude.texi.in > $@
 
-# For additional rules usually of interest only to the maintainer,
-# see GNUmakefile and Makefile.maint.
+tinc.texi: tincinclude.texi