Releasing 1.0.36.
[tinc] / doc / Makefile.am
index 09707ed..29d6ffd 100644 (file)
@@ -1,23 +1,35 @@
 ## Process this file with automake to get Makefile.in
 
 info_TEXINFOS = tinc.texi
+tinc_TEXINFOS = tincinclude.texi
 
-dyn_MANS = tincd.8
-man_aux = $(dyn_MANS:.8=.x)
+man_MANS = tincd.8 tinc.conf.5
 
-man_MANS = tinc.conf.5 genauth.8 $(dyn_MANS)
+EXTRA_DIST = tincinclude.texi.in tincd.8.in tinc.conf.5.in sample-config
 
-PERL = @PERL@
-HELP2MAN = help2man
-MAINTAINERCLEANFILES = $(dyn_MANS)
+CLEANFILES = *.html tincd.8 tinc.conf.5 tincinclude.texi
 
-EXTRA_DIST = $(man_MANS) $(HELP2MAN) $(man_aux) \
-  Makefile.maint GNUmakefile Makefile.summ tinc.conf.sample
+texi2html: tinc.texi
+       $(AM_V_GEN)texi2html -split=chapter $<
 
-# Use `ginstall' in the definition of man_MANS to avoid
-# confusion with the `install' target.  The install rule transforms `ginstall'
-# to install before applying any user-specified name transformations.
-transform = s/ginstall/install/; @program_transform_name@
+tincd.8.html: tincd.8
+       $(AM_V_GEN)w3mman2html $< > $@
 
-# For additional rules usually of interest only to the maintainer,
-# see GNUmakefile and Makefile.maint.
+tinc.conf.5.html: tinc.conf.5
+       $(AM_V_GEN)w3mman2html $< > $@
+
+substitute = sed \
+       -e s,'@PACKAGE\@',"$(PACKAGE)",g \
+       -e s,'@VERSION\@',"$(VERSION)",g \
+       -e s,'@sysconfdir\@',"$(sysconfdir)",g \
+       -e s,'@runstatedir\@',"$(runstatedir)",g \
+       -e s,'@localstatedir\@',"$(localstatedir)",g
+
+tincd.8: $(srcdir)/tincd.8.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tincd.8.in > $@
+
+tinc.conf.5: $(srcdir)/tinc.conf.5.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tinc.conf.5.in > $@
+
+tincinclude.texi: $(srcdir)/tincinclude.texi.in
+       $(AM_V_GEN)$(substitute) $(srcdir)/tincinclude.texi.in > $@