Conversion to struct addrinfo is almost complete for this file.
[tinc] / debian / rules
index 397e998..c07a054 100644 (file)
@@ -12,7 +12,16 @@ build: build-stamp
 build-stamp:
        dh_testdir
 
-       ./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info --sysconfdir=/etc
+#      # If the Makefile.in.in file in po/ already contains DESTDIR support, skip the patching.
+       cd `pwd`/po ; ( \
+         if ! grep DESTDIR Makefile.in.in > /dev/null ; then \
+           patch -Ns -p0 < `pwd`/../debian/po-Makefile.in.in.diff || true ;\
+         fi ;\
+       )
+
+       env CFLAGS='-O2 -Wall' ./autogen.sh --prefix=/usr --mandir=\$${prefix}/share/man \
+               --infodir=\$${prefix}/share/info --sysconfdir=/etc --localstatedir=/var
+
        $(MAKE)
 
        touch build-stamp
@@ -22,7 +31,7 @@ clean:
        dh_testroot
        rm -f build-stamp
 
-       -$(MAKE) distclean
+       -$(MAKE) cvs-clean
 
        dh_clean
 
@@ -33,10 +42,10 @@ install: build
        dh_installdirs
 
        $(MAKE) install DESTDIR=`pwd`/debian/tmp
-       mkdir -p `pwd`/debian/tmp/etc/tinc/example
-       cp doc/tinc.conf.sample `pwd`/debian/tmp/etc/tinc/example/tinc.conf
+       mkdir -p `pwd`/debian/tmp/etc/tinc
+       cp -a doc/sample-config.tar.gz `pwd`/debian/tmp/etc/tinc/example
+       cd `pwd`/debian/tmp/etc/tinc/example && tar xzf sample-config.tar.gz && rm sample-config.tar.gz
        ln -s /usr/share/doc/tinc/README.Debian `pwd`/debian/tmp/etc/tinc/example/README
-       rm -f `pwd`/debian/tmp/usr/lib/tinc/libblowfish.so
 
 
 # Build architecture-independent files here.
@@ -45,30 +54,21 @@ binary-indep: build install
 
 # Build architecture-dependent files here.
 binary-arch: build install
-#      dh_testversion
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
        dh_installdocs
        dh_installexamples
-#      dh_installmenu
-#      dh_installemacsen
-#      dh_installpam
        dh_installinit
-#      dh_installcron
        dh_installmanpages
+       dh_installmodules
        dh_installinfo
-#      dh_undocumented
        dh_installchangelogs ChangeLog
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
-#      # You may want to make some executables suid here.
-#      dh_suidregister
-#      dh_makeshlibs
        dh_installdeb
-#      dh_perl
+       dh_perl
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums