Update Depends lines to reflect the dependencies on OpenSSL
[tinc] / debian / rules
index de43c0d..397e998 100644 (file)
@@ -32,9 +32,11 @@ install: build
        dh_clean -k
        dh_installdirs
 
-       $(MAKE) install prefix=`pwd`/debian/tmp/usr
-       mkdir -p `pwd`/debian/tmp/etc/tinc
-       cp doc/tincd.conf.sample `pwd`/debian/tmp/etc/tinc/tincd.conf
+       $(MAKE) install DESTDIR=`pwd`/debian/tmp
+       mkdir -p `pwd`/debian/tmp/etc/tinc/example
+       cp doc/tinc.conf.sample `pwd`/debian/tmp/etc/tinc/example/tinc.conf
+       ln -s /usr/share/doc/tinc/README.Debian `pwd`/debian/tmp/etc/tinc/example/README
+       rm -f `pwd`/debian/tmp/usr/lib/tinc/libblowfish.so
 
 
 # Build architecture-independent files here.
@@ -49,11 +51,11 @@ binary-arch: build install
 #      dh_installdebconf       
        dh_installdocs
        dh_installexamples
-       dh_installmenu
+#      dh_installmenu
 #      dh_installemacsen
 #      dh_installpam
-#      dh_installinit
-       dh_installcron
+       dh_installinit
+#      dh_installcron
        dh_installmanpages
        dh_installinfo
 #      dh_undocumented
@@ -62,8 +64,8 @@ binary-arch: build install
        dh_strip
        dh_compress
        dh_fixperms
-       # You may want to make some executables suid here.
-       dh_suidregister
+#      # You may want to make some executables suid here.
+#      dh_suidregister
 #      dh_makeshlibs
        dh_installdeb
 #      dh_perl