Update Depends lines to reflect the dependencies on OpenSSL
[tinc] / debian / rules
index 74744d2..397e998 100644 (file)
@@ -1,4 +1,4 @@
-#!/bin/make -f
+#!/usr/bin/make -f
 # Sample debian/rules that uses debhelper.
 # GNU copyright 1997 to 1999 by Joey Hess.
 
@@ -32,9 +32,11 @@ install: build
        dh_clean -k
        dh_installdirs
 
-       $(MAKE) install prefix=`pwd`/debian/tmp/usr
-       mkdir -p `pwd`/debian/tmp/etc/tinc
-       cp doc/tincd.conf.sample `pwd`/debian/tmp/etc/tinc/tincd.conf
+       $(MAKE) install DESTDIR=`pwd`/debian/tmp
+       mkdir -p `pwd`/debian/tmp/etc/tinc/example
+       cp doc/tinc.conf.sample `pwd`/debian/tmp/etc/tinc/example/tinc.conf
+       ln -s /usr/share/doc/tinc/README.Debian `pwd`/debian/tmp/etc/tinc/example/README
+       rm -f `pwd`/debian/tmp/usr/lib/tinc/libblowfish.so
 
 
 # Build architecture-independent files here.